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Design Overview
The design shown in Figure 1 is an ARM7-based system that controls the analog peripherals in an Actel Fusion PSC. The ARM7 subsystem contains the following:

· Two UARTs – one to communicate with the RS-232-port and one to communicate with an Actel A3P250 used as a port expansion device to control the user interfaces such as the LCD, LEDs, keypad, etc.

· CoreAI – the ARM7 interface to the Fusion analog peripherals

· CoreNVM and CoreSRAM – the ARM7 interface to the Fusion Flash Memory and SRAM
This workshop guide will take you through all the steps from configuration of the ARM7 subsystem to programming an Actel Fusion M7AFS600 PSC on the Fusion System Management board. After programming, you will be able to run an ARM7 application from the Fusion Flash memory.
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Figure 1:  Block Diagram of ARM7 Subsystem
Lab 1

Creating the CoreMP7 Subsystem Using CoreConsole
Overview

In this lab, you will use the Actel CoreConsole IP Deployment Platform (IDP) to develop a CoreMP7 system that can be simulated and synthesized.

Key Objectives

Upon completion of this lab you will be able to do the following:

· Add ARM7 system components to a CoreConsole design project

· Connect the components using the CoreConsole Auto Stitch feature

· Configure the Fusion Analog peripherals

· Observe the memory map for the ARM7 subsystem

Step 1 – Opening CoreConsole
In this step, you will open CoreConsole and create a new design.

1. Double-click the Actel CoreConsole 1.2.1 icon on the desktop of your PC to open CoreConsole.

2. Choose New from the File menu. The New Design window will open, as shown in Figure 2.
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Figure 2:  New Design Window
3. Enter ARM7_ESC in the Design Name field, and click OK to create your design project.
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Figure 3:  CoreConsole
Step 2 – Adding AHB Components to the CoreConsole Project

In this step, you will add and stitch together CoreMP7, the AHB, CoreAhbNvm, CoreAhbSram in your design.

1. Select CoreMP7 in the Components tab of the Design Manager under Processors, and then click the Add button as shown in Figure 4.
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Figure 4:  CoreConsole Design Manager Components Tab
2. Add the CoreMP7Bridge and CoreAHBLite
 components from the Bus Interfaces section. After adding the three components, your design should resemble Figure 5.
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Figure 5:  CoreConsole Schematic Window after Entering Components 

3. Add the CoreAhbNvm and CoreAhbSram components from the Peripherals section by selecting the components and clicking the Add button.

4. Drag the components so that they appear as shown in Figure 6.
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Figure 6:  CoreConsole Schematic Window after Adding Components 

Step 3 – Connecting the AHB Components in the CoreConsole Project
In this step, you will use the CoreConsole Auto Stitch feature to connect the critical components of the system together automatically. You will still need to connect some of the top-level signals manually. Manual connection of some signals provides you with control over the microprocessor’s memory map.

1. Select Auto Stitch from the Actions menu. This displays the Auto Stitching window, shown in Figure 7.
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Figure 7:  CoreConsole Auto Stitching Window 

2. Confirm that stitching is enabled for all the components and that CoreAhbNvm_00 is AHBmslave0 and CoreAhbSram_00 is AHBmslave1, then click Stitch.
3. CoreAhbNvm provides an AHB interface to the embedded Flash memory blocks within Fusion devices. Configuring CoreAhbNvm as AHBmslave0 will force the ARM7 to boot from the Fusion Flash memory blocks.
4. After Auto Stitching is complete, your design should resemble Figure 8. If your schematic looks different, you can drag the components to the locations shown.
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Figure 8:  CoreConsole Schematic after Auto Stitching
Step 4 – Adding APB Components to the CoreConsole Project

In this step, you will add the APB components to the design.

1. Add the CoreAHB2APB and CoreAPB components from the Components tab of the Design Manager under Bus Interfaces.
2. Add the CoreAI component and two instances of the CoreUARTapb components from the Components tab of the Design Manager under Peripherals.

3. Use Auto Layout or drag the components so that the diagram resembles Figure 9.
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Figure 9:  CoreConsole Schematic after Adding APB Components
4. Perform another Auto Stitch to connect the APB components.  

5. Confirm that the new components are checked in the Auto Stitching dialog box, as shown in Figure 10.

6. Use the pull-down menus in the Auto Stitching dialog box to connect the peripherals to the bus slots indicated below.

· CoreAHB2APB_00:


AHBmslave12

· CoreUARTapb_00:


APBmslave3

· CoreUARTapb_01:


APBmslave5

· CoreAI_00:



APBmslave1
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Figure 10:  Auto Stitching the APB Peripherals
7. Click Stitch. After Auto Stitching, your schematic should appear as shown in Figure 11. You can drag components if necessary to make your diagram look like Figure 11.
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Figure 11:  CoreConsole Schematic after Auto Stitching APB Components

Step 5 – Configuring the Components in the CoreConsole Project

In this step, you will configure the components that were added to the CoreConsole project.

1. Float your mouse over the CoreMP7 component. An options toolbar will appear underneath the selected component, as shown in Figure 12.
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Figure 12:  Component Options Toolbar

2. Click the Configure icon (second from the left). Confirm the following are set in the Configuring CoreMP7_00 dialog box and click OK:

· Die:




M7AFS600

· Debug:



Enabled

· Speed Grade:


-2
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Figure 13:  CoreMP7 Configuration window

3. Click the Configure icon for the CoreMP7Bridge component. Set the following in the Configuring CoreMP7Bridge_00 dialog box and click OK:

· Debug:



RealView or FlashPro 3

· Synchronize nIRQ:


No

· Synchronize nFIQ:


No

· Device Family:


Fusion

4. Click the Configure icon for the CoreAhbSram component. Set the following in the Configuring CoreAhbSram_00 dialog box and click OK:

· Amount of internal SRAM required:
10Kbytes

· Device Family:


Fusion

5. Click the Configure icon for the CoreAI component. Set the following in the Configuring CoreAI_00 dialog box. Accept the default settings for all other options and click OK:

· AT0 input:



Temperature Monitor

· AT3 input:



Temperature Monitor

· AT4 input:



Temperature Monitor

· AC5 input:



0V to 8V analog input

· AT6 input:



Temperature Monitor

· AG6 output:



Software driven 25 mA sink

· AG7 output:



Software driven 25 mA sink

· AT8 input:



Temperature Monitor

· AG8 output:



Software driven 25 mA sink

· ADC MODE control:


Fixed constant

· ADC MODE fixed value:

12-bit

· TVC[7:0] pins control:

Fixed constant

· TVC[7:0] fixed value:

0

· STC[7:0] pins control:

Fixed constant

· STC[7:0] constant:


23

Step 6 – Making the Top-Level Connections

In this step, you will manually connect signals to the top level of the CoreMP7 system.  

1. Float your mouse over the CoreMP7Bridge component. Click the Connect icon (the leftmost icon, resembling a power plug) in the options toolbar.

2. Confirm that CoreMP7Bridge_00 appears in the From field of the Configuring Connection dialog box (if it does not appear, select it from the drop-down menu). Then select UJTAG from the From Pin(s) drop-down menu.

3. Select Top Level in the To drop-down menu. Enter the signal name UJTAG in the Connection Label box, as shown in Figure 14.
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Figure 14:  Connecting UJTAG Pins to the Top Level

4. Click Connect then OK in the Configuring Connection dialog box.

5. Float your mouse over the CoreUARTapb component in slot 3. Click the Connect icon to open the Configuring Connection dialog box.

6. Confirm that CoreUARTapb_00 appears in the From field of the Configuring Connection dialog box (if it does not appear, select it from the drop-down menu). Then select rx from the From Pin(s) drop-down menu.

7. Select Top Level in the To drop-down menu. Enter the signal name RS232_RX in the Connection Label box then click Connect.

8. Select tx from the From Pin(s) drop-down menu. Select Top Level in the To drop-down menu. Enter the signal name RS232_TX in the Connection Label box and then click Connect. Close the Configuring Connection dialog box by clicking OK.

9. Click the Connect icon for the CoreUARTapb_01 component in slot 5. Confirm that CoreUARTapb_01 appears in the From field of the Configuring Connection dialog box (if it does not appear, select it from the drop-down menu). Select rx from the From Pin(s) drop-down menu. Select Top Level in the To drop-down menu. Enter the signal name A3PUART_RX in the Connection Label box and then click Connect.

10. Select tx from the From Pin(s) drop-down menu. Select Top Level in the To drop-down menu. Enter the signal name A3PUART_TX in the Connection Label box. Click Connect then OK.

11. After making the connections to the top level, your design should resemble Figure 15.
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Figure 15:  ARM7 System after Making Top-Level Connections
Step 7 – Viewing the ARM7 Subsystem Memory Map and Generating the CoreConsole Design

In this step, you will view the ARM7 subsystem memory map and generate the Verilog or VHDL source code for the ARM7 subsystem.
1. Choose View > Memory Map from the CoreConsole menu. The Memory Map dialog box will open, as shown in Figure 16. Scroll in the window to observe the memory map and then close the window. You may need to expand the window to see all of the contents.
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Figure 16:  ARM7 Subsystem Memory Map
2. Select the Generate tab in the Design Manager.

3. Select the HDL language preference and then click the Save & Generate button.

4. Wait until both progress bars have reached 100%, as shown in Figure 17; this process can take up to 45 seconds depending on system complexity and PC resources.
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Figure 17:  Generating ARM7 System
5. Click OK in the Generate Complete box and minimize CoreConsole.

Lab 2

Importing the CoreMP7 Subsystem into an Actel Libero® Integrated Design Environment (IDE) Project

Overview

In this step, you will import the CoreMP7 system that was created in CoreConsole into an existing Libero IDE project, then simulate and synthesize the design.

Key Objectives

Upon completion of this lab you will be able to do the following:

· Import an ARM7 subsystem into Libero IDE
· Simulate the design using ModelSim® AE

· Enter timing constraints and synthesize the design with Synplify®
Step 1 – Opening Libero IDE and Importing the CoreConsole Project

1. Double-click the Actel Libero IDE v7.3 icon on the desktop of your PC to open Libero IDE.

2. Choose Open Project from the File menu. The Open dialog box will appear. Enter the following and click Open:

· Look in:
C:\Actelprj\ESC_2007\Libero_projects\VHDL\Workshop_1 or


C:\Actelprj\ESC_2007\Libero_projects\Verilog\Workshop_1
· File Name:
Workshop_1.prj

3. The Libero IDE project will open. The Design Hierarchy tab will display the source files in the project, as shown in Figure 18.
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Figure 18:  Libero Design Hierarchy Tab (VHDL shown)
4. From the File menu, choose Import Files. The Import Files window will open. Enter the following, as shown in Figure 19:

· Files of Type:
CoreConsole Projects [*.ccp]

· Look in:

C:\CoreConsole1.2.1\LiberoExport\ARM7_ESC
· File Name:

ARM7_ESC.ccp
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Figure 19:  Libero Import Files Dialog Box

5. Click Import to import the CoreConsole project created in Lab 1. The CoreConsole project files will be visible on the Libero IDE Design Hierarchy tab, as shown in Figure 20.
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Figure 20:  Libero IDE Project after Importing the CoreConsole Project

Step 2 – Simulating the ARM7 Design
In this step, you will simulate the ARM7 subsystem by performing a UART loopback test. The tx pin of each UART is connected to its rx pin in the testbench.  

1. Select the Libero IDE File Manager tab and double-click subsystem.bfm under the CoreConsole simulation files to open the file in the HDL editor (Figure 21).
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Figure 21:  CoreConsole Simulation Files (VHDL shown)

2. Edit the “Include resource scriptlets” section of the subsystem.bfm file and then save the file:

· Comment out the first three lines by adding the # sign at the beginning of each line.

· Edit the last two lines as shown at the bottom.

· Save the subsystem.bfm file.

#-----------------------------------------------------------

# Include resource scriptlets

#-----------------------------------------------------------


#include CoreAhbNvm CoreAhbNvm_00;

#include CoreAhbSram CoreAhbSram_00;

#include COREAI CoreAI_00;

include ESC_CoreUARTapb CoreUARTapb_00;

include ESC_CoreUARTapb CoreUARTapb_01;

3. Select the Libero IDE Design Hierarchy tab and confirm that ARM7_ESC appears in bold font. If it does not appear in bold font, select ARM7_ESC, right-click, and choose Set As Root.

4. Open the Organize Stimulus dialog box (Figure 22) by choosing Project > Files Organization > Stimulus from the Libero IDE menu.
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Figure 22:  Libero Organize Stimulus Dialog Box (VHDL shown)

5. Choose ARM7_testbench.v(hd) as the stimulus file as follows:

a. Choose testbench.v(hd) in the right-hand box and then click Remove.

b. Choose ARM7_testbench.v(hd) in the left-hand box and then click Add.

Click OK to close the Organize Stimulus dialog box.
6. Start ModelSim by clicking the Simulation button in the Libero IDE Design Flow window.
7. The ModelSim simulator will open. Observe the read and write cycles in the ModelSim Transcript window (Figure 23).
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Figure 23:  ModelSim Transcript Window
8. Restore CoreConsole and open the memory map for the ARM7 system by choosing View > Memory Map from the CoreConsole menu. Refer to the system memory map and the ModelSim transcript window to answer the following questions:

Which registers are being written?  _______________________________________________________________________

Which registers are being read?  _______________________________________________________________________

9. Close CoreConsole and the ModelSim simulator.

Step 3 – Synthesizing the Design

In this step, you will synthesize the design using Synplify.

1. Change the root to Top by selecting Top on the Libero IDE Design Hierarchy tab, right-clicking, and choosing Set As Root. Top will appear in bold font in the Design Hierarchy tab, and the Design Flow window will indicate Top is the root, as shown in Figure 24.
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Figure 24:  Root Indication in Design Flow Window

2. Open Synplify by clicking the Synplify Synthesis button in the Libero IDE Design Flow window. The Synplicity® GUI will open, as shown in Figure 25.
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Figure 25:  Synplify GUI

3. Click the RUN button to synthesize the design. When “Ready…” on the main user interface in Synplify changes to “Done…”, the design has been synthesized successfully. Synplify creates an EDIF netlist named Top.edn and a timing constraint file named Top_sdc.sdc that will be visible under Synthesis Files on the Libero IDE File Manager tab in the Design Explorer window (Figure 26).
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Figure 26:  EDIF Netlist and Timing Constraint File (VHDL and Verilog shown)

4. Close Synplify by choosing Exit from the Synplicity File menu. Click Yes if prompted about saving changes.

Lab 3
Layout and Post-Layout Analysis with Actel Designer

Overview

In this lab, you will import an EDIF netlist and constraint files, route the design, and create a programming file using the Actel Designer software.

Key Objectives

Upon completion of this lab you will be able to do the following:

· Import a netlist and constraint files into Designer

· Route the design

· Generate a programming file

Step 1 – Opening Designer and Importing Files

1. Open Designer by clicking the Designer Place & Route button in the Libero IDE Design Flow window. The Designer GUI will open, as shown in Figure 27, and the EDIF netlist and timing constraint file will be imported automatically.
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Figure 27:  Designer GUI

2. Accept the default values in the Device Selection Wizard window and click Next.
3. Click Next to accept the default values in the Device Selection Wizard – Variations window.
4. Click Finish to accept the default values in the Device Selection Wizard – Operating Conditions window.
5. Choose Import Source Files from the File menu. Choose Add, enter the following, as shown in Figure 28 and Figure 29, and click Import then OK. 

· Look in:

C:\Actelprj\ESC_2007\Libero_projects\VHDL\Workshop_1\constraint

· File name:

Top.pdc

· Files of type:
Physical Design Constraint (PDC) Files (*.pdc)
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Figure 28:  Adding Constraint Files
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Figure 29:  Adding Constraint Files

6. Accept the default options in the Import EDIF dialog box and click OK.
Step 2 – Compiling and Running Layout

In this step, you will run Compile and Layout on the design.

1. Compile the design by clicking the Compile button in the Designer GUI. Accept the default settings in the Compile Options dialog box and click OK.

Designer will compile the design. The Compile button in the Designer GUI will turn green to indicate that the compile step completed without errors.

2. Click the Layout button in the Designer GUI. The Layout Options dialog box will open, as shown in Figure 30.
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Figure 30:  Designer Layout Options

3. Click OK to accept the default settings and run Layout on the design. The Layout button in the Designer GUI will turn green when layout completes without any errors.

Step 3 – Generating the Programming File

In this step, you will generate the programming file for the M7AFS600.

1. Click the Programming File button in the Designer GUI.

2. Confirm the following are set in the FlashPoint – Programming File Generator dialog box, as shown in Figure 31:

· Output filename:



./Top.stp
· Silicon Features to be programmed:

· FPGA Array



Selected
· FlashROM



Cleared
· ARM7_inst/CoreAhbNvm_00

Cleared
· I/O preset before programming:

Tristate
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Figure 31:  FlashPoint Programming File Generator

3. Click Finish to generate the programming file. The Programming File button in the Designer GUI will turn green when the programming file has been generated.

4. Close Designer by choosing File > Exit. Click Yes if prompted about saving changes to Top.adb.

5. The programming file will be visible on the Libero IDE File Manger tab under Designer Views (Figure 32).
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Figure 32:  Programming File on Libero IDE File Manager Tab

Lab 4
Programming

Overview

In this lab, you will program the ARM7 design into an M7AFS600 on the Actel System Management board using FlashPro v5.1 and the FlashPro3 programmer.

Key Objectives

Upon completion of this lab, you will be able to do the following:

· Generate a programming file

· Launch FlashPro from Libero IDE
· Program an M7AFS600 and run an application from the Fusion NVM

Step 1 – Confirming Board Connections

1. Confirm that the power supply and FlashPro3 are connected to the board and that the serial cable is connected between the board and the serial port on your PC. Ask the lab instructor if you have any questions.

2. Apply power to the board by moving the on/off switch (SW7) to the ON position (Figure 33).
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Figure 33:  System Management Board Connections 
Step 2 – Programming the AFS600

1. Open the FlashPro software from Libero IDE by clicking the Programming button in the Libero IDE Design Flow window. The FlashPro GUI will open (Figure 34).

2. Look at the log window to confirm that the STAPL file was loaded, as indicated by the following message:
STAPL file 'C:\Actelprj\ESC_2007\Libero_projects\VHDL\Workshop_1_guide\designer\impl1\Top.stp' has been loaded successfully.
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Figure 34:  FlashPro GUI
3. Open the Single STAPL configuration window (Figure 35) by choosing View > Single STAPL Configuration from the FlashPro menu.
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Figure 35:  Single STAPL Configuration

4. Begin programming by clicking the RUN button on the FlashPro toolbar or by choosing Tools > Run from the menu.
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Figure 36:  FlashPro RUN Button

5. The Programming Status column in the Programmer list window indicates the programming progress. The Status will change to Run Passed to indicate that programming completed successfully (Figure 37).
Note: Do not interrupt the programming sequence; it may damage the device or the programmer. If you encounter any problems, contact the lab instructor.
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Figure 37:  FlashPro after Successfully Programming

6. Close FlashPro after programming the AFS600 by choosing File > Exit. Click Yes when prompted about saving the project.

7. After programming, the LCD will show the following message: 

“ACTEL & AVNET FUSION WORKSHOP”

8. Open the HyperTerminal session file by clicking the shortcut on the desktop of your PC.

[image: image40.png]&,

Shartcut to
ESC_uorkshap
Lht




Figure 38:  HyperTerminal Icon

9. Cycle the power to the board. The HyperTerminal window display will appear, as shown in the Figure 39.
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Figure 39:  Menu in HyperTerminal Application

10. Experiment with different commands to send messages to the LCD on the Fusion System Management board or read the temperature sensor and potentiometer.

11. When you are finished, close the HyperTerminal application; turn off the Fusion System Management board, and close Libero IDE.

Congratulations! You have successfully used the Libero IDE design flow from start to finish in creating a CoreMP7 design in an Actel Fusion FPGA.  

Note:  If you have time remaining, go to the appendix to learn how to perform timing and power analysis on this design.

Appendix
Timing and Power Analysis

Overview

In this lab, you will add timing constraints and perform a post-layout analysis of the ARM7 design using the SmartTime and SmartPower tools in Designer.

Key Objectives

Upon completion of this lab, you will be able to do the following:

· Add timing constraints

· Perform timing analysis

· Perform power analysis

Step 1 – Adding Timing Constraints

1. Open Designer by clicking the Designer Place & Route button in the Libero IDE Design Flow window. The Designer GUI will open, as shown in Figure 40.
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Figure 40:  Designer GUI

2. Open the SmartTime Constraint editor by clicking the Constraints Editor button in the Designer GUI. 

3. After the SmartTime Constraint editor opens, double-click Clock in the left-hand window, as shown in Figure 41.
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Figure 41:  Constraints Editor

4. The Create Clock Constraint  window will open. In the Clock Sources field, choose ARM7_inst/CoreAI_00/COREAI_oloi[1]:Q and enter 6.25 in the Frequency field (Figure 42). Keep the defaults for the rest of the fields and click OK.
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Figure 42:  Create Clock Constraint Window

5. Repeat step 4 above, creating the clock constraints below. When you are finished, the Constraints Editor should look like Figure 43.

Clock Sources: CLK_50MHZ

Frequency:  50 MHz

Clock Sources: TCK


Frequency:  20 MHz

Clock Sources: ClkDIV_inst/Inst1:GL
Frequency:  12.5 MHz
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Figure 43:  Timing Constraints

6. Save the constraints by going to File > Commit and then close SmartTime.

Step 2 – Running Layout and Analyzing Post-Layout Timing

In this step, you will run Layout on the design and analyze the post-layout timing to determine if any timing violations exist.

1. Click the Layout button in the Designer GUI. The Layout Options dialog box will open, as shown in Figure 44.
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Figure 44:  Designer Layout Options

2. Click OK to accept the default settings and run Layout on the design. The Layout button in the Designer GUI will turn green when layout completes without any errors.

3. Click the Timing Analyzer button in the Designer GUI to open the SmartTime Maximum Delay Analysis view, as shown in Figure 45. Look at the summary information to confirm that there are no timing violations. Timing violations are also indicated by a red X for clock domains in the leftmost window.
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Figure 45:  SmartTime Maximum Delay Analysis View

4. Close SmartTime by choosing File > Exit.

Step 4 – Power Analysis with SmartPower

In this step, you will use SmartPower to analyze the power consumption of the design.

1. Click the SmartPower button in the Designer GUI to open SmartPower. SmartPower will open and display the Summary tab, as shown in Figure 46. Note that the dynamic power is 0 mW.
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Figure 46:  SmartPower GUI

2. Select the Domains tab in the SmartPower GUI. Observe that all the clock frequencies are 0 MHz (Figure 47).
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Figure 47:  SmartPower Domains Tab

3. Import the clock frequencies from SmartTime by choosing Tools > Initialize Frequencies. Accept the default setting in the Initialize Frequencies dialog box and click OK. The clock frequencies from the SmartTime Constraint Editor will be visible under the SmartPower Domains tab (Figure 48).
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Figure 48:  SmartPower Domains Tab after Initializing Clock Frequencies

4. Select the Analysis tab in the SmartPower GUI. Observe the power consumption for the design and note that the dynamic power is no longer zero.

5. Expand the design hierarchy in the left window. Select different levels of hierarchy and observe the static and dynamic power for each level of hierarchy (Figure 49).
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Figure 49:  SmartPower Analysis Tab

6. Close SmartPower by choosing File > Close. Click Yes if prompted about saving changes.


For more information, visit our website at http://www.actel.com
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�This screen shot isn’t quite right.  The system defaults to not showing anything in the yellow window at the top left.  I have added a screen shot below this figure.


�Steps 2, 3, and 4 were are not written in parallel format to steps 1, 5, and 6.  Steps 1, 5, and 6 all use verbs as the first word.  This is a nit…but I did rewrite this section for parallism.


�This figure doesn’t “match” Figures 8 and 11.  UART should be shown under APB bus and SRAM core over AHBLite bus.


�You should add a Figure showing the top level bar on the system for users to verify.


�Should move Figure 18 here.


�My window looks different.  I don’ t have the “blackbox” line. I assume that this is because I am using Verilog.  Should we make a note of this?


�My simulation didn’t work.  I got fatal errors.


�I was prompted to choose the AFS600 device after this step before the next step.


�Just an FYI – my power was a little different for the Verilog version.
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